VM Start Protection Fails (PBM Error)
This article applies to all JSDR software versions.
Problem
The VM Start Protection task fails while applying the storage policy. The task logs may indicate the following error:
Cause
If the failure error references “PBM error occurred during PreReconfigureCallback” it may be caused by underlying vCenter server issues.
A potential cause of this issue may be a mismatch between the vCenter certificate and the host's "iofiltervp_castore.pem" certificate located in /etc/vmware/ssl
under the ESXi Host.
Solution
Ensure there are no underlying issues with vCenter server.
All JetStream DR appliances should be online and working as expected without any issues.
Confirm storage providers of the vCenter server are online.
(vCenter → Configure → Storage Providers)If they are offline, try using the Synchronize Storage Providers or Rescan options.
All storage providers must be online before starting VM protection. VM protection will fail if the IO Filter provider is offline.
If the issue persists or cannot be resolved, reach out to Microsoft Support [AVS] or VMware support [On-Prem] for assistance with resolving storage provider issues and bringing them online.
Additional Information
The following knowledge base articles from VMware can be consulted for information about setting the online status of storage providers.
Remove VASA Provider from the vSphere Storage Monitoring Service (SMS) mob
Resolving IOFilter disconnected/offline post upgrade to 7.0u2
Seek guidance from VMware support before attempting to implement the solutions described in these articles.