(vCenter Alarm) Replication Log Reserved Space Running Low

This article applies to all JSDR software versions.

Alarm

This alarm is triggered when the space reserved for the DRVA replication log is insufficient, leading to issues replicating and protecting VMs.

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Example: Alarm reported in vCenter.

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Example: Alarm definition in vCenter.

Possible Cause

  1. The alarm can be triggered when the reserved space for a replication log approaches its set threshold value.

    • The reserved size is not automatically adjusted by the system because free space is generally not available (but it can be manually adjusted as described below).

  2. Inadequate space allocated for the replication log volume.

    • The recommended log size calculation formula was not used when the replication log volume was initially created.

  3. The size of the protected domain metadata is too large for the assigned replication log volume.

    • The size of the protected domain should be consistent with size considered when initially configuring the replication log volume.

  4. Data failed to replicate to the object store for an extended period of time due to an underlying network issue.

Resolution

  1. Ensure the replication log is configured based upon recomendations from JetStream Software.

  2. Protected domains automatically allocate metadata from the replication log volume when they are created.

    • Ensure an appropriately sized replication log is used to support the protected domains.

  3. Keep track of the replication log space used when new VMs or protected domains are created.

    • If the metadata is too large for the replication log volume, consider reconfiguring it or using a different replication log volume.

    • Recalculate the replication log volume size based upon actual usage or follow recommendations from the Capacity Planning Tool.

  4. If the replication log volume has adequate free space, increase its reserved space:

    • Navigate to the Appliances tab

    • Select the DRVA.

    • Select the Replication Log Volume.

    • Select the Reserved Space.

    • Go to Configured Reserve Space Size and click the Configure link to specify a new size.

  1. To increase the size of the replication log volume:

    • Right-click the DRVA VM.

    • Increase the replication log disk (VMDK) size.

    • Reboot the DRVA to make the change become effective.

    • After the replication log volume has been resized, increase its reserved space (as described above in Step 4).

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