(vCenter Alarm) DRVA High CPU Usage Duration Exceeded
This article applies to all JSDR software versions.
Alarm
This alarm is triggered when the CPU usage of a DRVA has exceeded an acceptable threshold. The threshold is set for 90% lasting 15 minutes or longer. Excessive CPU usage can impact the performance and efficiency of DR operations.
Possible Cause
Excessive CPU usage can be caused by:
Increased Workload: A sudden spike in the replication of data, recovery operations, or adding more domains/VMs for protection can lead to higher CPU usage.
Resource Allocation: Insufficient CPU resources have been allocated to the DRVA.
Configuration: Improper configuration of the DRVA.
Resolution
Collect the MSA support bundle before proceeding with the following steps:
Verify the DRVA is adequately configured.
Ensure it is configured and meets the recommended specifications outlined in the Admin Guide.
Adjust CPU and memory allocation, if necessary.
Check processes running on the DRVA that may be consuming excessive CPU resources using the
top
command.Use the Capacity Planning Tool (CPT) and make necessary adjustments based on the collected statistics of protected VMs.
Analyze the workload of protected VMs.
If the workload has increased significantly, consider distributing the protected VM load over multiple protected domains/DRVAs.
Validate the vCenter stats of the DRVA VM related to CPU.
Observe the timestamp of any spikes and correlate them to environmental changes.
Try rebooting the DRVA and observe any change in status.
The system will automatically hot-add additional CPU to the DRVA if CPU resources are available to be added.
Contact Jetstream Support with MSA logs if you are unable to resolve the issue.